Author Topic: What does the host without proxy test actually test for?  (Read 3112 times)

anomie

  • Guest
What does the host without proxy test actually test for?
« on: April 14, 2011, 10:16:52 am »
I've been trying to get hosting without proxy set up.

I set my wireless router up to port forward 25710 and 25711 to the machine I run lackey on. I then try the in-game 'test if you can host without proxy' and it comes back saying I can't.

I've tried disabling UPnP, ddos protection, etc, even just setting the lackey box as a DMZ host, and the test never succeeds.

When I run the test, I see lackey bind to 25710 udp, while it's trying to test.

I don't have a somewhere-else-on-the-internet box I can test from, but if I bind netcat to port 25710 on the lackey box, and run a test connection (also using netcat) from another box inside my network to my external IP, I see the port forward trigger in my router logs.

Which makes me think that my problem is one of the following:
a) My ISP is blocking something (In which case, curse you ISP)
b) My router is doing something ridiculous, and also not logging whatever the ridiculousness is (in which case, curse you Netgear)
c) the test is checking for something other than just 'can it get a good udp response from Lackey by hitting the external IP', and that test is failing.

So - does the test fail out for reasons other than 'a udp packet to port 25710 can't get through'? (Basically, I'm looking to rule c in or out)
« Last Edit: April 14, 2011, 10:23:48 am by anomie »

Alastair

  • Forum Admin
  • Administrator
  • Sr. Member
  • *****
  • Posts: 450
  • LackeyCCG Forum Admin
    • View Profile
Re: What does the host without proxy test actually test for?
« Reply #1 on: April 14, 2011, 10:34:43 am »
You need to forward both TCP/IP and UDP on the required ports. And while your router may be forwarding the ports, you could have some firewall or antivirus application blocking it on your machine. Double check that. Also if you're on Vista or Win7 then  you might need to run lackey as administrator.

Hosting without proxy is the prefered way to host a game, since it bypasses the server. If you're playing a non-proxy game and the server goes down, your game continues.

anomie

  • Guest
Re: What does the host without proxy test actually test for?
« Reply #2 on: April 14, 2011, 11:20:50 am »
It is forwarding both TCP and UDP. When the test runs, only udp is being bound by the Lackey app (netstat shows udp4 *.25710). I've also already checked that it's not a local host firewall (I both added a rule, and tried shutting the mac firewall off completely, I should have stated that in my OP - also, when I bind using netcat and try the connection to my external IP, data flows in both directions, so it's definitely not a local host firewall).
« Last Edit: April 14, 2011, 11:28:56 am by anomie »

Trevor

  • LackeyCCG Creator
  • Administrator
  • Hero Member
  • *****
  • Posts: 2589
    • View Profile
    • LackeyCCG
Re: What does the host without proxy test actually test for?
« Reply #3 on: April 14, 2011, 12:20:21 pm »
You dont need to forward port 25711. That is used to connect to the server. If you can connect to the server already, you don't need to do anything with 25711.

What the test does is try to host a game, and tells the server your WAN IP. The server then sees if it can connect to you, in which case so will others, and hence you can host a normal game. If for some reason your WANIP is not reported correctly, or if you can't even start hosting the test game, that would also be a problem.
« Last Edit: April 14, 2011, 12:23:31 pm by Trevor »

anomie

  • Guest
Re: What does the host without proxy test actually test for?
« Reply #4 on: April 14, 2011, 12:36:20 pm »
That's what seemed most likely to me, and that rules c) out since I don't see the port forward trigger at all when the test itself is actually running. I just wanted to make sure there wasn't something else (For instance, the router has respond to ping on the WAN set off by default, I turned it on just in case the test tried to ping - of course, it made no difference, and based on this wouldn't, but I didn't know that at the time)

I've been trying to see if there's a list of ports blocked by my ISP somewhere, but haven't found anything. If I get it figured out I'll post the resolution.

Thanks!

anomie

  • Guest
Re: What does the host without proxy test actually test for?
« Reply #5 on: April 14, 2011, 01:04:33 pm »
I forgot about a shell account I had on my old ISP, so I tested using netcat from that shell account, to a netcat bound to 25710 on my mac (which is where I run Lackey), and that forwards through perfectly, using both tcp and udp. That means the port forward/firewall setup is fine, and my ISP isn't blocking the port. The external IP Lackey reports is also correct. I don't see any reason it shouldn't be working, at least from my end - but when I run the test in Lackey, I never see the port forwarding happen in the router logs.

I guess I'll have to use proxy. That or see if someone would be willing to try and see if the actual connection works even though the test fails.



« Last Edit: April 15, 2011, 12:06:45 am by anomie »

Picks-at-Flies

  • Guest
Re: What does the host without proxy test actually test for?
« Reply #6 on: April 14, 2011, 01:36:25 pm »
I'm curious:  if your ISP doesn't give you a fully reversible IP address, will that fail the test?

anomie

  • Guest
Re: What does the host without proxy test actually test for?
« Reply #7 on: April 14, 2011, 03:47:49 pm »
There are correct A and PTR records for the WAN IP. (assuming that's what you mean by fully reversible ...)

Picks-at-Flies

  • Guest
Re: What does the host without proxy test actually test for?
« Reply #8 on: April 14, 2011, 05:45:06 pm »
Sounds like it, I had to look up the terminology though :)

Rojer007

  • Guest
Re: What does the host without proxy test actually test for?
« Reply #9 on: May 09, 2011, 01:21:15 am »
i have installed isa server in my office.
what setting i need to work out