Author Topic: Lackey Missing Fonts error  (Read 2690 times)

eidolon276

  • Guest
Lackey Missing Fonts error
« on: September 25, 2015, 01:56:17 AM »
I get missing fonts error upon launching lackey and i cant play.. how do i fix it.
« Last Edit: September 25, 2015, 02:34:18 AM by Alastair »

Alastair

  • Forum Admin
  • Administrator
  • Sr. Member
  • *****
  • Posts: 439
  • LackeyCCG Forum Admin
    • View Profile
Re: Lackey Missing Fonts error
« Reply #1 on: September 25, 2015, 02:35:13 AM »
Does it tell you exactly which fonts are missing?

eidolon276

  • Guest
Re: Lackey Missing Fonts error
« Reply #2 on: September 25, 2015, 03:08:07 AM »
I'll screenshot it and link it

eidolon276

  • Guest
Re: Lackey Missing Fonts error
« Reply #3 on: September 25, 2015, 03:14:41 AM »
this is what I get "   
If you are seeing this webpage, it likely means that you tried to run the LackeyCCG program with no fonts available. Adjacent to the LackeyCCG program should be a folder called "fonts". Inside that should be one or more fonts. Valid font formats include .ttf and .dfont files. These fonts should have been included with the LackeyCCG you downloaded, but if you don't have them, you can get them from the downloads section."

Alastair

  • Forum Admin
  • Administrator
  • Sr. Member
  • *****
  • Posts: 439
  • LackeyCCG Forum Admin
    • View Profile
Re: Lackey Missing Fonts error
« Reply #4 on: September 25, 2015, 02:15:31 PM »
Ok, and is there a folder called fonts where you extracted the lackey zip file to? If so are there fonts in the folder?

Trevor

  • LackeyCCG Creator
  • Administrator
  • Hero Member
  • *****
  • Posts: 2589
    • View Profile
    • LackeyCCG
Re: Lackey Missing Fonts error
« Reply #5 on: November 14, 2015, 12:03:10 PM »
That is what happens if you try to run lackey app when it isn't adjacent to the folders that it needs to run, including fonts.

rgabriana

  • Guest
Re: Lackey Missing Fonts error
« Reply #6 on: January 07, 2016, 08:43:17 PM »
ran strace when I start mine up and pasted below are the results:
 
stat64("/home/shonuff/.wine/dosdevices/h:/LackeyCCG/fonts/plugins/fonts/Lato-Reg.ttf", 0x32f18c) = -1 ENOENT (No such file or directory)
stat64("/home/shonuff/.wine/dosdevices/h:/LackeyCCG", {st_mode=S_IFDIR|0777, st_size=4096, ...}) = 0
stat64("/home/shonuff/.wine/dosdevices/h:/LackeyCCG/fonts", {st_mode=S_IFDIR|0777, st_size=4096, ...}) = 0
stat64("/home/shonuff/.wine/dosdevices/h:/LackeyCCG/fonts/plugins", 0x32ee5c) = -1 ENOENT (No such file or directory)
open("/home/shonuff/.wine/dosdevices/h:/LackeyCCG/fonts", O_RDONLY|O_LARGEFILE|O_DIRECTORY) = 36


I basically fed the error the message and now it launches.