Author Topic: Lackey on Ubuntu "Fonts are missing"  (Read 5979 times)

7H0R

  • Guest
Lackey on Ubuntu "Fonts are missing"
« on: August 05, 2013, 06:34:12 PM »
Trying to run LackeyCCG through wine on Ubuntu. When it opens, it opens a webpage that has an error saying "If you see this, you are missing fonts. You can download them here" and links to the downloads page, which only has the downloads of the clients (Which should probably be fixed, just saying). I tried manually putting Arial and Times fonts in the font folder, but the same thing happens.

Trevor

  • LackeyCCG Creator
  • Administrator
  • Hero Member
  • *****
  • Posts: 2589
    • View Profile
    • LackeyCCG
Re: Lackey on Ubuntu "Fonts are missing"
« Reply #1 on: August 06, 2013, 08:46:40 AM »
The fonts are included in those downloads, which is why its linked there.

You should have fonts/times.ttf adjacent to the lackey exe. Things should work if you do. Can you confirm that you have that there?

tomtom

  • Guest
Re: Lackey on Ubuntu "Fonts are missing"
« Reply #2 on: August 26, 2013, 12:09:20 PM »
Hi
Slackware user here. I also can't run Lackey. Here's how it goes:
Code: [Select]
wine LackeyCCG.exe
preloader: Warning: failed to reserve range 00010000-00110000
preloader: Warning: failed to reserve range 00010000-00110000
preloader: Warning: failed to reserve range 00010000-00110000
preloader: Warning: failed to reserve range 00010000-00110000
preloader: Warning: failed to reserve range 00010000-00110000
preloader: Warning: failed to reserve range 00010000-00110000
fixme:heap:HeapSetInformation (nil) 1 (nil) 0
fixme:process:SetProcessDEPPolicy (1): stub
fixme:heap:HeapSetInformation (nil) 1 (nil) 0
preloader: Warning: failed to reserve range 00010000-00110000
preloader: Warning: failed to reserve range 00010000-00110000
fixme:win:EnumDisplayDevicesW ((null),0,0x32f334,0x00000000), stub!
fixme:win:EnumDisplayDevicesW (L"\\\\.\\DISPLAY1",0,0x32f334,0x00000000), stub!
fixme:win:EnumDisplayDevicesW (L"\\\\.\\DISPLAY1",0,0x32ef80,0x00000000), stub!
fixme:win:EnumDisplayDevicesW (L"\\\\.\\DISPLAY1",1,0x32f334,0x00000000), stub!
fixme:win:EnumDisplayDevicesW ((null),1,0x32f334,0x00000000), stub!
fixme:win:EnumDisplayDevicesW ((null),0,0x32f334,0x00000000), stub!
fixme:win:EnumDisplayDevicesW ((null),1,0x32f334,0x00000000), stub!
fixme:wgl:X11DRV_wglChoosePixelFormatARB unused pfAttribFList
fixme:imm:ImmReleaseContext (0x10066, 0x19fa48): stub
fixme:ole:CoCreateInstance no instance created for interface {3e90ade3-7594-4cb0-bb58-69628f5f458c} of class {529a9e6b-6587-4f23-ab9e-9c7d683e3c50}, hres is 0x80004002
fixme:imm:NotifyIME NI_CLOSECANDIDATE

The window named "LackeyCCG Windows" opens, but it remains blank (well, transparent in my case) and it stays like that forever. It's also pretty stubborn - I can't kill it by CTRL+C in the terminal window, it may be closed by  x on the window's bar however. What's pretty interesting, is that LackeyCCG process still works and does not surrender easily:

Code: [Select]
tomtom@tomtom:~$ ps ax |grep Lackey
 1696 pts/0    D+     0:00 LackeyCCG.exe                                     
 1972 pts/1    S+     0:00 grep Lackey
tomtom@tomtom:~$ kill 1696
tomtom@tomtom:~$ ps ax |grep Lackey
 1696 pts/0    D+     0:00 LackeyCCG.exe                                     
 1974 pts/1    S+     0:00 grep Lackey

Now comes the part described by the OP - when I try to run another instance of LackeyCCG it opens the webpage about missing fonts. The releveant part of code looks like that:

Code: [Select]
preloader: Warning: failed to reserve range 00010000-00110000

(process:2055): GLib-CRITICAL **: g_slice_set_config: assertion `sys_page_size == 0' failed
fout can't open{: secure/Preferences.txt
err:msctf:ThreadFocusHookProc Hook proc but no ThreadMgr for this thread. Serious Error

I assume the "can't open" error comes from the former LackeyCCG process still being open and thus not allowing new instance to access the files, font files included, but I have no idea why the window can't be created first place.

My wine version - 1.5.26.

Trevor

  • LackeyCCG Creator
  • Administrator
  • Hero Member
  • *****
  • Posts: 2589
    • View Profile
    • LackeyCCG
Re: Lackey on Ubuntu "Fonts are missing"
« Reply #3 on: August 26, 2013, 02:36:37 PM »
Try reading this post http://www.lackeyccg.com/forum/index.php?topic=2099.0

Let me know if those suggestions work.

tomtom

  • Guest
Re: Lackey on Ubuntu "Fonts are missing"
« Reply #4 on: August 26, 2013, 04:01:29 PM »
Already tried and implemented - didn't work. Cleaning .wine also didn't help. I'll try fresh install on another PC and let you know. As far as I can remember, I had managed to run Lackey about two years ago (not without a fight, but show me an app that doesn't require some boxing skills under wine), so there's still hope.

Trevor

  • LackeyCCG Creator
  • Administrator
  • Hero Member
  • *****
  • Posts: 2589
    • View Profile
    • LackeyCCG
Re: Lackey on Ubuntu "Fonts are missing"
« Reply #5 on: August 26, 2013, 11:19:39 PM »
The  "winetricks vcrun2008" thing worked for me when I last tested it.

tomtom

  • Guest
Re: Lackey on Ubuntu "Fonts are missing"
« Reply #6 on: August 29, 2013, 11:22:11 AM »
Vcrun has been installed already, unfortunately.
I upgraded to wine 1.7 - to no avail, but it got me rid of final "msctf serious error" message. Now it's just

Code: [Select]
(process:5322): GLib-CRITICAL **: g_slice_set_config: assertion `sys_page_size == 0' failed
fout can't open{: secure/Preferences.txt

I wonder what that mysterious "fout" is - maybe it's some weird misspelling in the code and it should state "font"?

Chris

  • Guest
Re: Lackey on Ubuntu "Fonts are missing"
« Reply #7 on: August 29, 2013, 12:01:24 PM »
'Fout' is Dutch for 'Error'...

tomtom

  • Guest
Re: Lackey on Ubuntu "Fonts are missing"
« Reply #8 on: August 29, 2013, 12:04:45 PM »
Thx! So why my wine talks to me in Dutch?

Chris

  • Guest
Re: Lackey on Ubuntu "Fonts are missing"
« Reply #9 on: August 29, 2013, 12:18:33 PM »
Sorry, not a clue. I just came across this post and thought a translation might help.
I don't know anything about Wine though. No idea why there should be any Dutch in there...

Trevor

  • LackeyCCG Creator
  • Administrator
  • Hero Member
  • *****
  • Posts: 2589
    • View Profile
    • LackeyCCG
Re: Lackey on Ubuntu "Fonts are missing"
« Reply #10 on: August 29, 2013, 02:44:51 PM »
Vcrun has been installed already, unfortunately.
I upgraded to wine 1.7 - to no avail, but it got me rid of final "msctf serious error" message. Now it's just

Code: [Select]
(process:5322): GLib-CRITICAL **: g_slice_set_config: assertion `sys_page_size == 0' failed
fout can't open{: secure/Preferences.txt

I wonder what that mysterious "fout" is - maybe it's some weird misspelling in the code and it should state "font"?
Funny about the dutch translation, but fout is the name of an ofstream object in c++. The ef denotes it is for a file stream, and the out denotes that it is for output. Similarly, the ifstream objects are usually called fin, because they are for file input.
This specific error is from my SavePreferences() function and it is caused because Lackey is trying to open a file at (Lackey's Folder)/secure/Preferences.txt and for some reason it can't. This is the file that stores general preferences, like which plugin you currently are using.
As far as why there is an error, I would guess that either your lackey doesn't have write permissions for where it is, or it can't write to that file for some other reason (like if you have it open).
It is also possible that it isn't recognizing the relative path from where the lackey exe is due to some operating system weirdness.
« Last Edit: August 29, 2013, 02:57:13 PM by Trevor »

Chris

  • Guest
Re: Lackey on Ubuntu "Fonts are missing"
« Reply #11 on: August 29, 2013, 04:09:37 PM »
Ow, haha. I guess that makes a lot more sense!  ;D

YokoZar

  • Guest
Re: Lackey on Ubuntu "Fonts are missing"
« Reply #12 on: September 01, 2013, 10:29:14 PM »
Hi, I'm Ubuntu's Wine maintainer :)

At any rate, I can confirm that winetricks vcrun2008 is needed to get the application to start, otherwise you get the fonts error.  If that didn't work for you, it's possible you didn't complete the install or similar.  You can try winetricks -q vcrun2008 to skip the dialog, or using a different wine prefix (similar to just deleting ~/.wine)

Trevor

  • LackeyCCG Creator
  • Administrator
  • Hero Member
  • *****
  • Posts: 2589
    • View Profile
    • LackeyCCG
Re: Lackey on Ubuntu "Fonts are missing"
« Reply #13 on: September 04, 2013, 01:39:24 PM »
I just updated the http://lackeyccg.com/linux.html page about the "winetricks vcrun2008" part of installation.