Author Topic: Anyone still using Mac 10.5, or 10.4 (or a PPC mac)?  (Read 3592 times)

Trevor

  • LackeyCCG Creator
  • Administrator
  • Hero Member
  • *****
  • Posts: 2589
    • View Profile
    • LackeyCCG
Anyone still using Mac 10.5, or 10.4 (or a PPC mac)?
« on: January 05, 2012, 02:52:30 pm »
I am considering only supporting Mac 10.6 and 10.7, which are the latest, and the 2nd most latest versions of the OS. I might also keep supporting 10.5, and just drop 10.4.

Supporting the older OS are a pain, and I'm wondering if anyone still uses those. If there is a decent amount of old mac OS users out there, let me know.

Anyone know any statistics on mac users and what OS they use?

Nava

  • Jr. Member
  • **
  • Posts: 72
  • Maintainer startrek2e and tribbles plugins
    • View Profile
Re: Anyone still using Mac 10.5, or 10.4 (or a PPC mac)?
« Reply #1 on: January 06, 2012, 10:56:07 am »
I am considering only supporting Mac 10.6 and 10.7, which are the latest, and the 2nd most latest versions of the OS. I might also keep supporting 10.5, and just drop 10.4.

Supporting the older OS are a pain, and I'm wondering if anyone still uses those. If there is a decent amount of old mac OS users out there, let me know.

Anyone know any statistics on mac users and what OS they use?

One stat would be from StatOwl Usage Shares (without knwing how this was sampled). Skip the chart and have a look at October that should at least give you a hint. Btw 10.5 was the last OS for PPC systems, so older computers will not upgrade from there...

Nava

institute

  • Guest
Re: Anyone still using Mac 10.5, or 10.4 (or a PPC mac)?
« Reply #2 on: January 06, 2012, 02:53:19 pm »
Hi Trev,

I use 10.5 on a laptop that I play on as well as having 10.6 on my desktop. 10.5 is still fairly common. People have been slow to move to 10.7. I would keep supporting 10.5 forward and drop 10.4.

As for PPC I just moved from my old trusty G5 and which still could run 10.5 so I would say don't obsolete PPC just yet. Just drop 10.4.

My two bits,

Institute

Trevor

  • LackeyCCG Creator
  • Administrator
  • Hero Member
  • *****
  • Posts: 2589
    • View Profile
    • LackeyCCG
Re: Anyone still using Mac 10.5, or 10.4 (or a PPC mac)?
« Reply #3 on: January 06, 2012, 03:50:13 pm »
Hi Trev,

I use 10.5 on a laptop that I play on as well as having 10.6 on my desktop. 10.5 is still fairly common. People have been slow to move to 10.7. I would keep supporting 10.5 forward and drop 10.4.

As for PPC I just moved from my old trusty G5 and which still could run 10.5 so I would say don't obsolete PPC just yet. Just drop 10.4.

My two bits,

Institute
The pain is maintaining PPC. If I am going to maintain PPC, I will also be maintaining 10.4.

Kanashimi

  • Guest
Re: Anyone still using Mac 10.5, or 10.4 (or a PPC mac)?
« Reply #4 on: January 08, 2012, 06:13:18 am »
I'm running on 10.4.11 on a PPC G4, however I'm not sure there are enough users to warrant the continued support of PPC. I know most applications no longer support it.

jamtronix

  • Guest
Re: Anyone still using Mac 10.5, or 10.4 (or a PPC mac)?
« Reply #5 on: January 08, 2012, 12:14:18 pm »
Yup still using OS 10.4 until I can afford another Mac.

Reth

  • Newbie
  • *
  • Posts: 45
    • View Profile
Re: Anyone still using Mac 10.5, or 10.4 (or a PPC mac)?
« Reply #6 on: July 13, 2014, 10:36:00 am »
Though I do know that this is a really old thread I just want to add that I am using a Powerbook with MacOS 10.5.8 PPC (since I can also run MorphOS on it).
Would be great if LackeyCCG would be available for that architecture (MacOS PPC) too.

Is LackeyCCG OpenSource or somehow available for porting (for interested programmers for example)?

Trevor

  • LackeyCCG Creator
  • Administrator
  • Hero Member
  • *****
  • Posts: 2589
    • View Profile
    • LackeyCCG
Re: Anyone still using Mac 10.5, or 10.4 (or a PPC mac)?
« Reply #7 on: July 13, 2014, 01:40:56 pm »
Though I do know that this is a really old thread I just want to add that I am using a Powerbook with MacOS 10.5.8 PPC (since I can also run MorphOS on it).
Would be great if LackeyCCG would be available for that architecture (MacOS PPC) too.

Is LackeyCCG OpenSource or somehow available for porting (for interested programmers for example)?
Sorry, it's not open source. Apple seems to really be pushing for developers not to support really old operating systems. I'm trying to at least support 10.6, which is still tricky.

muesli pariah

  • Guest
Re: Anyone still using Mac 10.5, or 10.4 (or a PPC mac)?
« Reply #8 on: July 14, 2014, 11:46:46 pm »
I'm running 10.6.8 and can't get the new version to run. Error message says to check with developer that the application runs with this OS version. I tried downloading it again, no luck.

Is 10.6 no longer supported after all?

Trevor

  • LackeyCCG Creator
  • Administrator
  • Hero Member
  • *****
  • Posts: 2589
    • View Profile
    • LackeyCCG
Re: Anyone still using Mac 10.5, or 10.4 (or a PPC mac)?
« Reply #9 on: July 15, 2014, 08:23:42 am »
I'm running 10.6.8 and can't get the new version to run. Error message says to check with developer that the application runs with this OS version. I tried downloading it again, no luck.

Is 10.6 no longer supported after all?
Actually, I think I fixed the 10.6 issue yesterday (according to one person who tested it). I will post that fix soon.

muesli pariah

  • Guest
Re: Anyone still using Mac 10.5, or 10.4 (or a PPC mac)?
« Reply #10 on: July 16, 2014, 09:41:48 pm »
Thanks, I appreciate it.